Jump to content
Sign in to follow this  
freaktmp

Επισκευή Commodore 128

Recommended Posts

Προ καιρου περασε στα χερια μου ενας Commodore 128 για ολιγα ευρω. Συμπαθέστατο οπως ολα τα μηχανηματα της αγαπημένης μου εταιριας, αν και προτιμω το 128DCR.

 

large.image_67940.jpg.a6f9b2bed4e6a86fb7

 

 

Δυστυχως οταν το εβαλα μπροστα δοκίμασα μια δυσαρεστη εκπληξη.

 

Μαυρα χαλια.

 

large.image_67891.jpg.f01c8e51fd81a3fea1

 

large.image_67890.jpg.7e76f05beefb345e7e

 

 

Πως θα επρεπε να δειχνει κανονικα: ο 128DCR με το ιδιο καλωδιο SCART

 

large.image_67939.jpg.d67775e98e38c07a4f

 

large.image_67889.jpg.051da7675a25a50c1d

 

 

Με RF δειχνει κανονικα, αλλα η ποιοτητα απεικόνισης ειναι ετσι κι αλλιως χαμηλοτερη.

 

large.image_67938.jpg.d88ee30035cda12aaf

 

 

Επειδη μετα τις περιπετειες με τα Atari προτιμω να αφιερωνω λιγο περισσότερο χρονο χρησιμοποιώντας (=παιζωντας με) τα μηχανηματα και λιγο λιγότερο κατσαβιδιαζωντας τα, οταν βρηκα motherboard σε τιμη ευκαιριας το χτυπησα.

 

Εξι βιδες μας δινουν προσβαση στο εσωτερικο

 

large.image_82736.jpg.63570fc8c6de87445a

 

 

Προσεκτικα σηκωνουμε το πανω μερος του υπολογιστη. Αποσυνδεουμε το βυσμα του power led, την γειωση του πληκτρολογιου και το καλωδιο του πληκτρολογιου.

 

large.image_82737.jpg.28c11a2398a2e354fe

 

 

7 βιδες στερεωνουν το motherboard στο κατω μερος του υπολογιστη. Μια βιδα ακομη συν μια σειρα απο μεταλλικά ελάσματα ασφαλίζουν την πανω EMI ασπιδα στο motherboard. Ιδιαιτερη προσοχη χρειαζεται στα 4 ελασματα που βρισκονται στο κεντρο της πανω ασπιδας και την κρατουν στερεωμενη στον πλαστικο στύλο που διαπερνά το motherboard.

 

large.image_82738.jpg.fe54904979833b68d2

 

 

Επειδη η πανω EMI ασπιδα εχει μια δευτερη λειτουργία σαν ψήκτρα για τα διαφορα ολοκληρωμένα, πρεπει να δωσουμε ιδιαιτερη προσοχη οταν την τοποθετούμε στην θεση της, ετσι ωστε να ασφαλισει σωστα και να πιεζει ολα τα ολοκληρωμένα που πρεπει να ψυχονται απο αυτη.

 

Αφου ολα μπουν στη θεση τους, το απαραιτητο test drive με το Ms Pacman cartridge μου. Success!!!

 

large.image_82739.jpg.2d5a54ac6d6b5cfe7a

Edited by freaktmp
Αποκατάσταση εικόνων

Share this post


Link to post
Share on other sites

Αν ποτε εχεις ελευθερο χρονο και θες να πειραματιστεις, εχω εναν παραξενα πεθαμενο C128 που δεν μπορει να παθει κατι χειροτερο απο οτι ειναι χαχαχαχα :)

Share this post


Link to post
Share on other sites

Aπο την στιγμη που δειχνει καλα στο rf η βλαβη μπορει να ειναι και κατι απλο,πχ ψυχρη κολληση...και αφου την εβγαλες μπορεις να πειραματιστεις ανετα;)

Share this post


Link to post
Share on other sites

Τωρα που εχω εναν σιγουρα καλο C128, καποια στιγμη θα ριξω μια ματια και στο board που εβγαλα... αλλα παει στο μακρυνο μελλον.

 

Τωρα wally για το δικο σου, αν θες το στελνεις και το ξεχνας, και αμα ερθει η καταλληλη ωρα θα ελεγχει. Οπως καταλαβαινεις, ειναι αναγκαστικα σε χαμηλη προτεραιοτητα!

Share this post


Link to post
Share on other sites
Αν ποτε εχεις ελευθερο χρονο και θες να πειραματιστεις, εχω εναν παραξενα πεθαμενο C128 που δεν μπορει να παθει κατι χειροτερο απο οτι ειναι χαχαχαχα :)

 

...και ειμαστε και εμεις εδω:)

Share this post


Link to post
Share on other sites

Πηγα να παιξω τις προαλλες με τον 128, παω να τον βαλω μπροστα, ακουω κατι περιεργα απο το την μερια του τροφοδοτικου και νεκρα! Μαυρη μαυριλα στην οθονη.

 

Αφου ηρθε στα χερια μου το super τροφοδοτικο του Ray Carlsen, ειπα να του ριξω μια δευτερη ματια. Το αποτελεσμα το ιδιο.

 

Ειπα λοιπον να παρω ενα dead test cartridge απο το ebay, μηπως και μας δωσει μια αποψη του τι συμβαινει. Το αγορασα φυσικα σκετο, γιατι το συνοδευτικο wiring harness κοστιζει μια περιουσια.

 

P1191490.thumb.JPG.540f005e49dbf25e6418c86f68145bbd.JPG

 

Ε δεν προλαβα να το καρφωσω πανω και ο ατιμος ο 128 πηρε μπροστα κανονικα! Εκανε ομως καποια τσαλιμια (δεν ξεκιναγε σωστα παντα με την πρωτη).

 

Το διαγνωστικο δεν παρουσιαζει κανενα προβλημα. Αυτα που λεει οτι ειναι bad ειναι λογω οτι δεν βρισκει το wiring harness.

 

P1171489.thumb.JPG.b40353176587ab965a198b562fbb641e.JPG

 

Εκανα reseat ολα τα ολοκληρωμενα που ειναι σε sockets, εκανα reflow τον διακοπτη on/off και το βυσμα τροφοδοσιας και αλλαξα τους 4 μεγαλυτερους πυκνωτες και πλεον ξεκιναει σωστα 90% με την πρωτη!

 

Μελλοντικα σκεφτομαι να ξεφορτωθω το EMI shield και να βαλω dedicated ψυκτρες στα ολοκληρωμενα.

 

 

Edited by freaktmp
Αποκατάσταση εικόνων
  • Like 2

Share this post


Link to post
Share on other sites
Μελλοντικα σκεφτομαι να ξεφορτωθω το EMI shield και να βαλω dedicated ψυκτρες στα ολοκληρωμενα.

 

Αυτό έκανα κι εγώ από την πρώτη στιγμή ;-)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...